Changing http-requests conditionally











up vote
1
down vote

favorite












I'm new to RXJS and I have a working piece of code for http-request and subscribing to Observables from a shared service in Angular. This works, but I'd want to get rid of the nested subscriptions, which I know is probably very possible with RXJS operators, but I haven't figured out how. The usage of flatMap in the nested request wouldn't be necessary, as the second nested request isn't dependable on the first.



  this.sub = this.service.isPending$
.subscribe(data => {
if(data) { // gives boolean
this.service.getPending()
.subscribe((data:Offer) => this.offer = data)
} else {
this.sub2 = this.service.amount$
.flatMap((data: Amount) => {
this.amount = data;
return this.service.getOffer()
})
.subscribe((data: Offer) => {
this.offer = data;
})
}
})


How would I go about cleaning this code up? I'm using RXJS: "^5.0.1"










share|improve this question
















bumped to the homepage by Community yesterday


This question has answers that may be good or bad; the system has marked it active so that they can be reviewed.



















    up vote
    1
    down vote

    favorite












    I'm new to RXJS and I have a working piece of code for http-request and subscribing to Observables from a shared service in Angular. This works, but I'd want to get rid of the nested subscriptions, which I know is probably very possible with RXJS operators, but I haven't figured out how. The usage of flatMap in the nested request wouldn't be necessary, as the second nested request isn't dependable on the first.



      this.sub = this.service.isPending$
    .subscribe(data => {
    if(data) { // gives boolean
    this.service.getPending()
    .subscribe((data:Offer) => this.offer = data)
    } else {
    this.sub2 = this.service.amount$
    .flatMap((data: Amount) => {
    this.amount = data;
    return this.service.getOffer()
    })
    .subscribe((data: Offer) => {
    this.offer = data;
    })
    }
    })


    How would I go about cleaning this code up? I'm using RXJS: "^5.0.1"










    share|improve this question
















    bumped to the homepage by Community yesterday


    This question has answers that may be good or bad; the system has marked it active so that they can be reviewed.

















      up vote
      1
      down vote

      favorite









      up vote
      1
      down vote

      favorite











      I'm new to RXJS and I have a working piece of code for http-request and subscribing to Observables from a shared service in Angular. This works, but I'd want to get rid of the nested subscriptions, which I know is probably very possible with RXJS operators, but I haven't figured out how. The usage of flatMap in the nested request wouldn't be necessary, as the second nested request isn't dependable on the first.



        this.sub = this.service.isPending$
      .subscribe(data => {
      if(data) { // gives boolean
      this.service.getPending()
      .subscribe((data:Offer) => this.offer = data)
      } else {
      this.sub2 = this.service.amount$
      .flatMap((data: Amount) => {
      this.amount = data;
      return this.service.getOffer()
      })
      .subscribe((data: Offer) => {
      this.offer = data;
      })
      }
      })


      How would I go about cleaning this code up? I'm using RXJS: "^5.0.1"










      share|improve this question















      I'm new to RXJS and I have a working piece of code for http-request and subscribing to Observables from a shared service in Angular. This works, but I'd want to get rid of the nested subscriptions, which I know is probably very possible with RXJS operators, but I haven't figured out how. The usage of flatMap in the nested request wouldn't be necessary, as the second nested request isn't dependable on the first.



        this.sub = this.service.isPending$
      .subscribe(data => {
      if(data) { // gives boolean
      this.service.getPending()
      .subscribe((data:Offer) => this.offer = data)
      } else {
      this.sub2 = this.service.amount$
      .flatMap((data: Amount) => {
      this.amount = data;
      return this.service.getOffer()
      })
      .subscribe((data: Offer) => {
      this.offer = data;
      })
      }
      })


      How would I go about cleaning this code up? I'm using RXJS: "^5.0.1"







      typescript angular-2+ rxjs






      share|improve this question















      share|improve this question













      share|improve this question




      share|improve this question








      edited Dec 7 '17 at 3:00









      Jamal

      30.2k11115226




      30.2k11115226










      asked Oct 5 '17 at 12:36









      DRNR

      91




      91





      bumped to the homepage by Community yesterday


      This question has answers that may be good or bad; the system has marked it active so that they can be reviewed.







      bumped to the homepage by Community yesterday


      This question has answers that may be good or bad; the system has marked it active so that they can be reviewed.
























          1 Answer
          1






          active

          oldest

          votes

















          up vote
          0
          down vote













          On Observables



          My personal preference is to have as few Subscription objects and subscribe() invocations as possible. If I don't have mistakes in the refactored code, you can achieve a single subscribe() which does the same things as your code. I also got rid of sub2.



          this.offerSubscription = this.service
          .isPending$
          .flatMap(data => {
          this.amount = null;
          const offerObservable = data ?
          this.service.getPending() :
          this.service
          .amount$
          .flatMap((data: Amount) => {
          this.amount = data;
          return this.service.getOffer();
          });
          return offerObservable;
          })
          .subscribe((offer: Offer) => this.offer = offer);


          On TypeScript



          sub, sub2, isPending$ and data are pretty bad names because they don't describe the entities they hold. I recommend changing them.



          At the bare minimum, specify the type of the input parameter in your arrow function to make the code more readable: (data: Offer) => {...} or better (receivedOffer: Offer) => { ... }.






          share|improve this answer























          • Specifying the type of a callback parameter is very much like an implicit type assertion and masks the introduction of any.
            – Aluan Haddad
            Mar 12 at 9:45













          Your Answer





          StackExchange.ifUsing("editor", function () {
          return StackExchange.using("mathjaxEditing", function () {
          StackExchange.MarkdownEditor.creationCallbacks.add(function (editor, postfix) {
          StackExchange.mathjaxEditing.prepareWmdForMathJax(editor, postfix, [["\$", "\$"]]);
          });
          });
          }, "mathjax-editing");

          StackExchange.ifUsing("editor", function () {
          StackExchange.using("externalEditor", function () {
          StackExchange.using("snippets", function () {
          StackExchange.snippets.init();
          });
          });
          }, "code-snippets");

          StackExchange.ready(function() {
          var channelOptions = {
          tags: "".split(" "),
          id: "196"
          };
          initTagRenderer("".split(" "), "".split(" "), channelOptions);

          StackExchange.using("externalEditor", function() {
          // Have to fire editor after snippets, if snippets enabled
          if (StackExchange.settings.snippets.snippetsEnabled) {
          StackExchange.using("snippets", function() {
          createEditor();
          });
          }
          else {
          createEditor();
          }
          });

          function createEditor() {
          StackExchange.prepareEditor({
          heartbeatType: 'answer',
          convertImagesToLinks: false,
          noModals: true,
          showLowRepImageUploadWarning: true,
          reputationToPostImages: null,
          bindNavPrevention: true,
          postfix: "",
          imageUploader: {
          brandingHtml: "Powered by u003ca class="icon-imgur-white" href="https://imgur.com/"u003eu003c/au003e",
          contentPolicyHtml: "User contributions licensed under u003ca href="https://creativecommons.org/licenses/by-sa/3.0/"u003ecc by-sa 3.0 with attribution requiredu003c/au003e u003ca href="https://stackoverflow.com/legal/content-policy"u003e(content policy)u003c/au003e",
          allowUrls: true
          },
          onDemand: true,
          discardSelector: ".discard-answer"
          ,immediatelyShowMarkdownHelp:true
          });


          }
          });














          draft saved

          draft discarded


















          StackExchange.ready(
          function () {
          StackExchange.openid.initPostLogin('.new-post-login', 'https%3a%2f%2fcodereview.stackexchange.com%2fquestions%2f177216%2fchanging-http-requests-conditionally%23new-answer', 'question_page');
          }
          );

          Post as a guest















          Required, but never shown

























          1 Answer
          1






          active

          oldest

          votes








          1 Answer
          1






          active

          oldest

          votes









          active

          oldest

          votes






          active

          oldest

          votes








          up vote
          0
          down vote













          On Observables



          My personal preference is to have as few Subscription objects and subscribe() invocations as possible. If I don't have mistakes in the refactored code, you can achieve a single subscribe() which does the same things as your code. I also got rid of sub2.



          this.offerSubscription = this.service
          .isPending$
          .flatMap(data => {
          this.amount = null;
          const offerObservable = data ?
          this.service.getPending() :
          this.service
          .amount$
          .flatMap((data: Amount) => {
          this.amount = data;
          return this.service.getOffer();
          });
          return offerObservable;
          })
          .subscribe((offer: Offer) => this.offer = offer);


          On TypeScript



          sub, sub2, isPending$ and data are pretty bad names because they don't describe the entities they hold. I recommend changing them.



          At the bare minimum, specify the type of the input parameter in your arrow function to make the code more readable: (data: Offer) => {...} or better (receivedOffer: Offer) => { ... }.






          share|improve this answer























          • Specifying the type of a callback parameter is very much like an implicit type assertion and masks the introduction of any.
            – Aluan Haddad
            Mar 12 at 9:45

















          up vote
          0
          down vote













          On Observables



          My personal preference is to have as few Subscription objects and subscribe() invocations as possible. If I don't have mistakes in the refactored code, you can achieve a single subscribe() which does the same things as your code. I also got rid of sub2.



          this.offerSubscription = this.service
          .isPending$
          .flatMap(data => {
          this.amount = null;
          const offerObservable = data ?
          this.service.getPending() :
          this.service
          .amount$
          .flatMap((data: Amount) => {
          this.amount = data;
          return this.service.getOffer();
          });
          return offerObservable;
          })
          .subscribe((offer: Offer) => this.offer = offer);


          On TypeScript



          sub, sub2, isPending$ and data are pretty bad names because they don't describe the entities they hold. I recommend changing them.



          At the bare minimum, specify the type of the input parameter in your arrow function to make the code more readable: (data: Offer) => {...} or better (receivedOffer: Offer) => { ... }.






          share|improve this answer























          • Specifying the type of a callback parameter is very much like an implicit type assertion and masks the introduction of any.
            – Aluan Haddad
            Mar 12 at 9:45















          up vote
          0
          down vote










          up vote
          0
          down vote









          On Observables



          My personal preference is to have as few Subscription objects and subscribe() invocations as possible. If I don't have mistakes in the refactored code, you can achieve a single subscribe() which does the same things as your code. I also got rid of sub2.



          this.offerSubscription = this.service
          .isPending$
          .flatMap(data => {
          this.amount = null;
          const offerObservable = data ?
          this.service.getPending() :
          this.service
          .amount$
          .flatMap((data: Amount) => {
          this.amount = data;
          return this.service.getOffer();
          });
          return offerObservable;
          })
          .subscribe((offer: Offer) => this.offer = offer);


          On TypeScript



          sub, sub2, isPending$ and data are pretty bad names because they don't describe the entities they hold. I recommend changing them.



          At the bare minimum, specify the type of the input parameter in your arrow function to make the code more readable: (data: Offer) => {...} or better (receivedOffer: Offer) => { ... }.






          share|improve this answer














          On Observables



          My personal preference is to have as few Subscription objects and subscribe() invocations as possible. If I don't have mistakes in the refactored code, you can achieve a single subscribe() which does the same things as your code. I also got rid of sub2.



          this.offerSubscription = this.service
          .isPending$
          .flatMap(data => {
          this.amount = null;
          const offerObservable = data ?
          this.service.getPending() :
          this.service
          .amount$
          .flatMap((data: Amount) => {
          this.amount = data;
          return this.service.getOffer();
          });
          return offerObservable;
          })
          .subscribe((offer: Offer) => this.offer = offer);


          On TypeScript



          sub, sub2, isPending$ and data are pretty bad names because they don't describe the entities they hold. I recommend changing them.



          At the bare minimum, specify the type of the input parameter in your arrow function to make the code more readable: (data: Offer) => {...} or better (receivedOffer: Offer) => { ... }.







          share|improve this answer














          share|improve this answer



          share|improve this answer








          edited Oct 8 '17 at 1:28

























          answered Oct 7 '17 at 22:44









          Igor Soloydenko

          2,773928




          2,773928












          • Specifying the type of a callback parameter is very much like an implicit type assertion and masks the introduction of any.
            – Aluan Haddad
            Mar 12 at 9:45




















          • Specifying the type of a callback parameter is very much like an implicit type assertion and masks the introduction of any.
            – Aluan Haddad
            Mar 12 at 9:45


















          Specifying the type of a callback parameter is very much like an implicit type assertion and masks the introduction of any.
          – Aluan Haddad
          Mar 12 at 9:45






          Specifying the type of a callback parameter is very much like an implicit type assertion and masks the introduction of any.
          – Aluan Haddad
          Mar 12 at 9:45




















          draft saved

          draft discarded




















































          Thanks for contributing an answer to Code Review Stack Exchange!


          • Please be sure to answer the question. Provide details and share your research!

          But avoid



          • Asking for help, clarification, or responding to other answers.

          • Making statements based on opinion; back them up with references or personal experience.


          Use MathJax to format equations. MathJax reference.


          To learn more, see our tips on writing great answers.





          Some of your past answers have not been well-received, and you're in danger of being blocked from answering.


          Please pay close attention to the following guidance:


          • Please be sure to answer the question. Provide details and share your research!

          But avoid



          • Asking for help, clarification, or responding to other answers.

          • Making statements based on opinion; back them up with references or personal experience.


          To learn more, see our tips on writing great answers.




          draft saved


          draft discarded














          StackExchange.ready(
          function () {
          StackExchange.openid.initPostLogin('.new-post-login', 'https%3a%2f%2fcodereview.stackexchange.com%2fquestions%2f177216%2fchanging-http-requests-conditionally%23new-answer', 'question_page');
          }
          );

          Post as a guest















          Required, but never shown





















































          Required, but never shown














          Required, but never shown












          Required, but never shown







          Required, but never shown

































          Required, but never shown














          Required, but never shown












          Required, but never shown







          Required, but never shown







          Popular posts from this blog

          Quarter-circle Tiles

          build a pushdown automaton that recognizes the reverse language of a given pushdown automaton?

          Mont Emei